Fix for "GLX error: Can not get required symbols" in Xorg log file / No 3D graphics with radeon Open source driver

If you get the error: "(EE) GLX error: Can not get required symbols" when trying to use the open source "radeon" driver, and you have AMD's fglrx installed, I will tell you a very simple and fast fix. Most people will recommend to completely uninstall the fglrx driver, but there is much simpler and faster fix for that.

First, check if this is really the issue:
sudo /usr/lib/fglrx/switchlibglx query

If the command tells you that the AMD driver is currently in use, you have to switch to the "intel" driver in order to use the open source radeon driver. This is also very simple:

sudo /usr/lib/fglrx/switchlibglx intel

Now restart your X Server, or your computer if you wish, and you should be all set! And if you want to use fglrx again, remember to switch back with:
sudo /usr/lib/fglrx/switchlibglx amd

Enjoy! And let me know if this worked for you!

No comments:

Post a Comment

I appreciate comments. And I do read them.