Downloading Packages for Expired Ubuntu Releases

When Ubuntu releases expire, the package archive mirror is disabled as well. You will get error messages when trying to access e.g. archive.ubuntu.com or de.archive.ubuntu.com. (e.g. http://security.ubuntu.com/ubuntu/dists/karmic-security/main/binary-i386/Packages.gz not found.)
But the fix is easy:
In /etc/apt/sources.list, simply replace the url archive.ubuntu.com with old-releases.ubuntu.com and you can download your old and outdated packages again! And next time, if you can, try to select a long term support (LTS) release, so you have security fixes for a longer time. Because you warned these packages won't have security updates.

No comments:

Post a Comment

I appreciate comments. And I do read them.